class AttributeService¶
- class NemAll_Python_BaseElements.AttributeService¶
Implementation of the attribute service
- class AttributeControlType¶
Attribute control types
- Calculate = NemAll_Python_BaseElements.AttributeControlType.Calculate¶
- CheckBox = NemAll_Python_BaseElements.AttributeControlType.CheckBox¶
- ComboBox = NemAll_Python_BaseElements.AttributeControlType.ComboBox¶
- ComboBoxFilling = NemAll_Python_BaseElements.AttributeControlType.ComboBoxFilling¶
- ComboBoxFixed = NemAll_Python_BaseElements.AttributeControlType.ComboBoxFixed¶
- ComboBoxHatch = NemAll_Python_BaseElements.AttributeControlType.ComboBoxHatch¶
- ComboBoxPattern = NemAll_Python_BaseElements.AttributeControlType.ComboBoxPattern¶
- Edit = NemAll_Python_BaseElements.AttributeControlType.Edit¶
- Undef = NemAll_Python_BaseElements.AttributeControlType.Undef¶
- __module__ = 'NemAll_Python_BaseElements'¶
- class AttributeSelectionDialogType¶
Type of the attribute selection dialog
- __module__ = 'NemAll_Python_BaseElements'¶
- eAllAttributes = NemAll_Python_BaseElements.AttributeSelectionDialogType.eAllAttributes¶
- eInsertAttributes = NemAll_Python_BaseElements.AttributeSelectionDialogType.eInsertAttributes¶
- eProjectAttributes = NemAll_Python_BaseElements.AttributeSelectionDialogType.eProjectAttributes¶
- class AttributeType¶
Attribute types
- ByteVec = NemAll_Python_BaseElements.AttributeType.ByteVec¶
- Date = NemAll_Python_BaseElements.AttributeType.Date¶
- Double = NemAll_Python_BaseElements.AttributeType.Double¶
- DoubleVec = NemAll_Python_BaseElements.AttributeType.DoubleVec¶
- Enum = NemAll_Python_BaseElements.AttributeType.Enum¶
- Integer = NemAll_Python_BaseElements.AttributeType.Integer¶
- IntegerVec = NemAll_Python_BaseElements.AttributeType.IntegerVec¶
- String = NemAll_Python_BaseElements.AttributeType.String¶
- StringVec = NemAll_Python_BaseElements.AttributeType.StringVec¶
- Undef = NemAll_Python_BaseElements.AttributeType.Undef¶
- __module__ = 'NemAll_Python_BaseElements'¶
- AddUserAttribute(doc: DocumentAdapter, attributeType: AttributeType, attributeName: str, attributeDefaultValue: str, attributeMinValue: float, attributeMaxValue: float, attributeDimension: str, attributeCtrlType: AttributeControlType, attributeListValues: VecStringList) int ¶
Add a user attribute
- Args:
doc:                    Document
attributeType:          Type
attributeName:          Name
attributeDefaultValue:  Default value
attributeMinValue:      Minimal value
attributeMaxValue:      Maximal value
attributeDimension:     Dimension
attributeCtrlType:      Control type
attributeListValues:    List with the allowed attribute values- Returns:
ID of the added user attribute, -1 = not possible to add
- GetAttributeID(doc: DocumentAdapter, attributeName: str) int ¶
Get the attribute ID
- Args:
doc:            Document
attributeName:  Attribute name- Returns:
Attribute ID
- GetAttributeName(doc: DocumentAdapter, attributeID: int) str ¶
Get the attribute type
- Args:
doc:          Document
attributeID:  Attribute ID- Returns:
Attribute type
- GetAttributeType(doc: DocumentAdapter, attributeID: int) AttributeType ¶
Get the attribute type
- Args:
doc:          Document
attributeID:  Attribute ID- Returns:
Attribute type
- GetDefaultValue(doc: DocumentAdapter, attributeID: int) object ¶
Get the default value of an attribute
- Args:
doc:          Document
attributeID:  Attribute ID- Returns:
Default value of the attribute
- GetEnumIDFromValueString(attributeID: int, valueString: str) int ¶
Get the enumeration ID from the value string
- Args:
attributeID:  Attribute ID
valueString:  Value string- Returns:
Enumeration ID
- GetEnumValueStringFromID(attributeID: int, enumID: int) str ¶
Get the enumeration value string from the enumeration ID
- Args:
attributeID:  Attribute ID
enumID:       Enumeration ID- Returns:
Enumeration value string
- GetEnumValues(doc: DocumentAdapter, attributeID: int) list(std::str] ¶
Get the enum attribute values
- Args:
doc:          Document
attributeID:  Attribute ID- Returns:
Default attribute value
- GetInputListValues(doc: DocumentAdapter, attributeID: int) list(std::str] ¶
Get the input list values
- Args:
doc:          Document
attributeID:  Attribute ID- Returns:
Attribute input list values
- OpenAttributeSelectionDialog(doc: DocumentAdapter, dialogType: AttributeSelectionDialogType) int ¶
Open the attribute selection dialog
- Args:
doc:         Document
dialogType:  Dialog type- Returns:
Attribute ID
- __init__()¶
This class cannot be instantiated from Python
- ByteVec = NemAll_Python_BaseElements.AttributeType.ByteVec¶
- Calculate = NemAll_Python_BaseElements.AttributeControlType.Calculate¶
- CheckBox = NemAll_Python_BaseElements.AttributeControlType.CheckBox¶
- ComboBox = NemAll_Python_BaseElements.AttributeControlType.ComboBox¶
- ComboBoxFilling = NemAll_Python_BaseElements.AttributeControlType.ComboBoxFilling¶
- ComboBoxFixed = NemAll_Python_BaseElements.AttributeControlType.ComboBoxFixed¶
- ComboBoxHatch = NemAll_Python_BaseElements.AttributeControlType.ComboBoxHatch¶
- ComboBoxPattern = NemAll_Python_BaseElements.AttributeControlType.ComboBoxPattern¶
- Date = NemAll_Python_BaseElements.AttributeType.Date¶
- Double = NemAll_Python_BaseElements.AttributeType.Double¶
- DoubleVec = NemAll_Python_BaseElements.AttributeType.DoubleVec¶
- Edit = NemAll_Python_BaseElements.AttributeControlType.Edit¶
- Enum = NemAll_Python_BaseElements.AttributeType.Enum¶
- Integer = NemAll_Python_BaseElements.AttributeType.Integer¶
- IntegerVec = NemAll_Python_BaseElements.AttributeType.IntegerVec¶
- String = NemAll_Python_BaseElements.AttributeType.String¶
- StringVec = NemAll_Python_BaseElements.AttributeType.StringVec¶
- Undef = NemAll_Python_BaseElements.AttributeControlType.Undef¶
- __module__ = 'NemAll_Python_BaseElements'¶
- eAllAttributes = NemAll_Python_BaseElements.AttributeSelectionDialogType.eAllAttributes¶
- eInsertAttributes = NemAll_Python_BaseElements.AttributeSelectionDialogType.eInsertAttributes¶
- eProjectAttributes = NemAll_Python_BaseElements.AttributeSelectionDialogType.eProjectAttributes¶