class Point3D

class NemAll_Python_Geometry.Point3D

Representation class for 3D point

GetCoords() Tuple[float, float, float]

Get copy of X,Y,Z coordinates

Returns:

tuple(X coordinate of point,
      Y coordinate of point,
     Z coordinate of point)

GetDistance(point: Point3D) float

Get distance

Formula: Result(double) = |A-B|.

Args:

point:  Point3D.

Returns:

double.

IsZero() bool

Check the coords [0.0, 0.0, 0.0]

If the coords are zero, the return value is true. If the coords aren’t zero, the return value is false.

Returns:

bool.

Set(...)
Set(point: Point3D) None

Initialize from point 3D.

Args:

point:  Point.

Set(x: float, y: float, z: float) None

Initialize from x,y,z coordinates.

Args:

x:  coordinate.
y:  coordinate.
z:  coordinate.

Values() list(double]

Get copy of X,Y,Z coordinates as python list

Returns:

X coordinate of point,
Y coordinate of point,
Z coordinate of point

__add__(...)
__add__(vec: Vector3D) Point3D

Move the point by vector 3D

Args:

vec:  Vector

Returns:

New point

__add__(vec: Vector2D) Point3D

Move the point by vector 2D. Z axis will be ignored

Args:

vec:  Vector

Returns:

New point

__add__(point: Point3D) Point3D

Point translation by point

Formula: Point(new) = Point(this) + Point

This is not standard math operation and is implemented only as practical use case for point moving in %Allplan. In this case given operand point represent offset from Zero point. For standard move operation please use Service::Move method with Vector3D operand.

Args:

point:  Point.

Returns:

Point.

__eq__(point: Point3D) bool

Comparison of points without tolerance.

Be careful, this method work without tolerance!

Args:

point:  Compared point.

Returns:

True when points are equal, otherwise false.

__iadd__(point: Point3D) Point3D

Point translation by point

Formula: Point(this) = Point(this) + Point

This is not standard math operation and is implemented only as practical use case for point moving in %Allplan. In this case given operand point represent offset from Zero point. For standard move operation please use Service::Move method with Vector3D operand.

Args:

point:  Point.

Returns:

Point.

__idiv__(divider: float) Point3D

Divide operator.

Formula:

Point(this).X = Point(this).X / divider Point(this).Y = Point(this).Y / divider Point(this).Z = Point(this).Z / divider

This method is checked and throwing Geometry::Exception when divider is zero.

Args:

divider:  Divider.

Returns:

Point.

__init__(...)
__init__() None
__init__(point: Point3D) None

Copy constructor.

Args:

point:  Point which will be copied.

__init__(point: Point2D) None

Explicit copy constructor.

Copy only X_COORD and Y_COORD from point, Z_COORD is set to zero.

Args:

point:  2D Point which will be copied to the 3D point.

__init__(refPoint: Point3D, point: Point3D) None

Constructor.

Initialize point from point in local coordinate system. Formula: Result = refPoint + point

Args:

refPoint:  Reference point.
point:     Relative point

__init__(x: float, y: float, z: float) None

Constructor

Initialize point from single coordinates in world coordinate system.

Args:

x:  X coordinate of point
y:  Y coordinate of point
z:  Z coordinate of point

__isub__(point: Point3D) Point3D

Point translation by negative point

Formula: Point(this) = Point(this) - Point

This is not standard math operation and is implemented only as practical use case for point moving in %Allplan. In this case given operand point represent offset from Zero point. For standard move operation please use Service::Move method with Vector3D operand.

Args:

point:  Point.

Returns:

Point.

__mul__(...)
__mul__(matrix: Matrix2D) Point3D

2D matrix transformation.

Result = Point * matrix

Args:

matrix:  2D transformation Matrix

Returns:

Point.

__mul__(matrix: Matrix3D) Point3D

3D matrix transformation.

Result = Point * matrix

Args:

matrix:  3D transformation Matrix

Returns:

Point.

__mul__(scale: float) Point3D

Scale point with constant

Result = Point * scale

Args:

scale:  - scale factor

Returns:

scaled Point

__ne__(point: Point3D) bool

Comparison of points without tolerance.

Be careful, this method work without tolerance!

Args:

point:  Compared point.

Returns:

True when points are not equal, otherwise false.

__repr__() str

Convert to string

__sub__(...)
__sub__(vec: Vector3D) Point3D

Move the point by reversed vector 3D

Args:

vec:  3D vector

Returns:

New point

__sub__(vec: Vector2D) Point3D

Move the point by reversed vector 2D. Z coordinate stays unchanged.

Args:

vec:  2D vector

Returns:

New point

__sub__(point: Point3D) Point3D

Point translation by negative point

Formula: Point(new) = Point(this) - Point

This is not standard math operation and is implemented only as practical use case for point moving in %Allplan. In this case given operand point represent offset from Zero point. For standard move operation please use Service::Move method with Vector3D operand.

Args:

point:  Point3D.

Returns:

Point.

__truediv__(divider: float) Point3D

Divide operator.

Formula:

Point(new).X = Point(this).X / divider Point(new).Y = Point(this).Y / divider Point(new).Z = Point(this).Z / divider

Args:

divider:  Divider.

Returns:

Point.

property X: float

Get the x coordinate

Set the x coordinate

property Y: float

Get the y coordinate

Set the y coordinate

property Z: float

Get the z coordinate

Set the z coordinate

__module__ = 'NemAll_Python_Geometry'