class ElementAdapterType¶
- class NemAll_Python_IFW_ElementAdapter.ElementAdapterType¶
Implementation of the element type
- GetDisplayName() str ¶
Get the display name of the element
- Returns:
Display name
- GetGuid() GUID ¶
Get the GUID
- Returns:
GUID of the element type
- GetModelType() GUID ¶
Get the model type
- Returns:
Model type
- GetTypeName() str ¶
Get the type name of the element
- Returns:
Type name of the element
- GetZoomState() object ¶
Get the zoom state of the element type
- Returns:
Zoom state
- Is3DElement() bool ¶
Get the 3D element state
- Returns:
Element has 3D geometry: true/false
- IsInfoFromParent() bool ¶
Get the element state for the element info
- Returns:
Use the element info from the parent element: true/false
- __eq__(guid: GUID) bool ¶
Equal operator
- Args:
guid:  Type to compare
- Returns:
Types are equal: true/false
- __init__()¶
This class cannot be instantiated from Python
- __ne__(guid: GUID) bool ¶
Not equal operator
- Args:
guid:  Type to compare
- Returns:
Types are equal: true/false
- property IsVisible: bool¶
Get the visible state of the element type
Set the visible state of the element type
- __module__ = 'NemAll_Python_IFW_ElementAdapter'¶