TextProperties class¶
- class NemAll_Python_BasisElements.TextProperties¶
Implementation of the text properties
- GetRatio() float ¶
Get ration height/width
- Init() None ¶
Init section properties with default values
- IsDraftText() bool ¶
check eDraftText property flag
return true if eDraftText is set otherwise return false
- SetHasBackgroundColorAndTransparentBackgroundColor(value: bool) None ¶
- Args:
value:  
- __eq__(prop: TextProperties) object ¶
equal operator
- Args:
prop:  TextProperties to compare
- Returns:
true if they are equal, false otherwise
- __init__(...)¶
- __init__() None ¶
- __init__(element: TextProperties) None ¶
Copy constructor
- Args:
element:  Element to copy
- __repr__() str ¶
Convert to string
- property Alignment: eTextAlignment¶
Get the Alignment of text
Set the Alignment of text
- property BackgroundColor: int¶
Get the Background color of text
Set the Background color of text
- property ColumnSlopeAngle: Angle¶
DocFiles/Geometry/General/Angle_Class;NemAll_Python_Geometry.Angle$ of columns in [rad]
Set the Angle of columns in [rad]
- Type
Get the $LINK
- property Expansion: NEM_UBYTE_t¶
Get the Background color of text
Set the Background color of text
- property Font: int¶
Get the font ID
Set the font ID
- property FontAngle: Angle¶
DocFiles/Geometry/General/Angle_Class;NemAll_Python_Geometry.Angle$ of characters (italic) in [rad]
Set the Angle of characters (italic) in [rad]
- Type
Get the $LINK
- property HasBackgroundColor: bool¶
check eHasTextBgColor property flag
return true if eHasTextBgColor is set otherwise return false
Set eHasTextBgColor flag
- property HasReferencePoint: bool¶
check eHasReferencePoint property flag
return true if eHasReferencePoint is set otherwise return false
Set eHasReferencePoint flag
- property HasTextFrame: bool¶
check text frame active
return true if text frame is active otherwise return false
Set text frame active
- property HasTransparentBackground: bool¶
check eHasTransparentBackground property flag
return true if eHasTransparentBackground is set otherwise return false
Set eHasTransparentBackground flag
- property Height: double¶
Get the Height of text in [mm]
Set the Height of text in [mm]
- property IsScaleDependent: bool¶
check eIsScaleDependent property flag
return true if eIsScaleDependent is set otherwise return false
Set scale dependent flag
- property IsUserModifiable: bool¶
Check if user can modify text
return true if user can modify text
Set negation of the eNotUserModifiable flag
- property LineFeed: float¶
Get the Line feed of text in [mm]
Set the Line feed of text in [mm]
- property TextAngle: Angle¶
DocFiles/Geometry/General/Angle_Class;NemAll_Python_Geometry.Angle$ of hole text in [rad]
Set the Angle of hole text in [rad]
- Type
Get the $LINK
- property TextFrame: TextFrameStruct¶
Get the Text frame pen, stroke color settings
Set the Text frame pen, stroke color settings
- property TextFrameColor: int¶
Get text frame color value
Set text frame color value
- property TextFramePen: int¶
Get text frame pen value
Set text frame pen value
- property TextFrameStroke: int¶
Get text frame stroke value
Set text frame stroke value
- property Type: eTextType¶
Get the Text type (0 - normal text, >1 variables textbild (itv))
Set the Text type (0 - normal text, >1 variables textbild (itv))
- property Width: double¶
Get the Width of text in [mm]
Set the Width of text in [mm]
- __module__ = 'NemAll_Python_BasisElements'¶