Axis Properties
Class full path: NemAll_Python_ArchElements.AxisProperties
Axis properties
Attributes
Distance: float
property
writable
Distance between axis and the outer side of the architectural element
Extension: int
property
writable
Axis extension. Assuming the axis is drawn from left right:
- 1: Normal - architectural element is generated above the axis
- -1: Mirrored - architectural element is generated below the axis
Modus: int
property
writable
Modus
OnLayer: int
property
writable
Layer index, on which the axis is placed. First layer has the index 1. Relevant only for multi-layer objects, like ex. walls.
Position: WallAxisPosition
property
writable
Axis position relative to the architectural element
Classes
WallAxisPosition
Bases: IntEnum
Position of the wall axis
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
Union[str, int, float]
|
value key |
required |
Returns:
Type | Description |
---|---|
WallAxisPosition
|
value for the key |
Functions
__init__()
initialize
__repr__()
convert the list to a string