Room Properties
Class full path: NemAll_Python_ArchElements.RoomProperties
Bases: ArchBaseProperties
Implementation of the Room properties
Attributes
Function: str
property
writable
Room Function
StoreyCode: str
property
writable
Storey code
Functions
GetAttributes(doc, onlyModifiable)
Get the room attributes
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
onlyModifiable
|
bool
|
when true, gets only modifiable attributes, otherwise gets all attributes |
required |
Returns:
Type | Description |
---|---|
List[Tuple[int, Union[int, float, str]]]
|
List with the attributes represented with tuples like (attributeID, attributeValue) |
GetFunction()
Get the function
Returns:
Type | Description |
---|---|
str
|
Function |
GetStoreyCode()
Get the storey code
Returns:
Type | Description |
---|---|
str
|
Storey code |
GetText(number)
Get the text
Parameters:
Name | Type | Description | Default |
---|---|---|---|
number
|
int
|
Number (1-5 allowed) |
required |
Returns:
Type | Description |
---|---|
str
|
Text |
SetAttribute(attrib)
Set the attribute
Parameters:
Name | Type | Description | Default |
---|---|---|---|
attrib
|
Union[AttributeInteger, AttributeDouble, AttributeString, AttributeEnum]
|
Attribute |
required |
SetFunction(name)
Set the function
Parameters:
Name | Type | Description | Default |
---|---|---|---|
name
|
str
|
Function |
required |
SetStoreyCode(storeyCode)
Set the storey code
Parameters:
Name | Type | Description | Default |
---|---|---|---|
storeyCode
|
str
|
Storey code |
required |
SetText(text, number)
Set the attributes Text1 to Text5
Parameters:
Name | Type | Description | Default |
---|---|---|---|
text
|
str
|
Text |
required |
number
|
int
|
Number (1-5 allowed) |
required |
__init__
overload
__init__()
initialize
__init__(RoomProp)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
RoomProp
|
RoomProperties
|
Room properties |
required |