Solid Element Truncation Type
Class full path: NemAll_Python_ArchElements.SolidElementTruncationType
Bases: IntEnum
Type of cutting/stretching method of structural element at its start or end
Attributes
FreePlane = 3
class-attribute
instance-attribute
Cutting with any plane
Horizontal = 1
class-attribute
instance-attribute
Horizontal cutting
NormalToBodyAxis = 0
class-attribute
instance-attribute
Perperpendicular to the element axis
Vertical = 2
class-attribute
instance-attribute
Vertical cutting
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
Union[str, int, float]
|
value key |
required |
Returns:
Type | Description |
---|---|
SolidElementTruncationType
|
value for the key |