Structural Beam Properties
Class full path: NemAll_Python_ArchElements.StructuralBeamProperties
Bases: StructuralElementProperties
, ArchBaseProperties
Implementation of Structural Framing Beam properties
Functions
GetEndPoint()
Get the end point of the element in world coordinate system
Returns:
Type | Description |
---|---|
Point3D
|
End point |
GetStartPoint()
Get the start point of the element in world coordinate system
Returns:
Type | Description |
---|---|
Point3D
|
Start point |
SetAnchorPointProperties(anchorPointStart, offsetStart, anchorPointEnd, offsetEnd, twoAnchorPoints)
Set the Beam Anchor Points Properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
anchorPointStart
|
CustomBoxPoint
|
anchor point position |
required |
offsetStart
|
Point2D
|
offset from start anchor point |
required |
anchorPointEnd
|
CustomBoxPoint
|
anchor point position |
required |
offsetEnd
|
Point2D
|
offset from end anchor point |
required |
twoAnchorPoints
|
bool
|
true when both anchor points are used |
required |
SetEndPoint(x, y, z)
Set the end point of the element in world coordinate system
Parameters:
Name | Type | Description | Default |
---|---|---|---|
x
|
float
|
y end point coordinate |
required |
y
|
float
|
y end point coordinate |
required |
z
|
float
|
z end point coordinate |
required |
SetHeightProperties(doc, planeReferences)
Set HeightProperties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
planeReferences
|
PlaneReferences
|
Height Properties of Column, as PlaneReferences type |
required |
SetHeightPropsByPlacementPoints(doc, planeReferences, zCoordAtStart, zCoordAtEnd)
Set Height properties using placement points
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
planeReferences
|
PlaneReferences
|
Plane References |
required |
zCoordAtStart
|
float
|
Z coordinate of the start point |
required |
zCoordAtEnd
|
float
|
Z coordinate of the end point |
required |
SetStartPoint(x, y, z)
Set the start point of the element in world coordinate system
Parameters:
Name | Type | Description | Default |
---|---|---|---|
x
|
float
|
y end point coordinate |
required |
y
|
float
|
y end point coordinate |
required |
z
|
float
|
z end point coordinate |
required |
__init__
overload
__init__()
initialize
__init__(structuralBeamProps)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
structuralBeamProps
|
StructuralBeamProperties
|
Structural Beam properties |
required |