Structural Brace Properties
Class full path: NemAll_Python_ArchElements.StructuralBraceProperties
Bases: StructuralElementProperties
, ArchBaseProperties
Implementation of Structural Framing Brace properties
Functions
GetEndPoint()
Get the end point of the element in world coordinate system
Returns:
Type | Description |
---|---|
Point3D
|
End point |
GetStartPoint()
Get the start point of the element in world coordinate system
Returns:
Type | Description |
---|---|
Point3D
|
Start point |
SetAnchorPointProperties(anchorPointStart, offsetStart, anchorPointEnd, offsetEnd, twoAnchorPoints)
Set the Brace Anchor Points Properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
anchorPointStart
|
CustomBoxPoint
|
anchor point position |
required |
offsetStart
|
Point2D
|
offset from start anchor point |
required |
anchorPointEnd
|
CustomBoxPoint
|
anchor point position |
required |
offsetEnd
|
Point2D
|
offset from end anchor point |
required |
twoAnchorPoints
|
bool
|
True when different anchor points at start and at end should be used, False otherwise |
required |
SetEndPoint(x, y, z)
Set the end point of the element in world coordinate system
Parameters:
Name | Type | Description | Default |
---|---|---|---|
x
|
float
|
y end point coordinate |
required |
y
|
float
|
y end point coordinate |
required |
z
|
float
|
z end point coordinate |
required |
SetHeightProperties(doc, planeReferences)
Set Height Properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
planeReferences
|
BasePlaneReferences
|
Plane References |
required |
SetHeightPropsByPlacementPoints(doc, planeReferences, zCoordAtStart, zCoordAtEnd)
Set Height Properties using placement points
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
planeReferences
|
BasePlaneReferences
|
Plane References |
required |
zCoordAtStart
|
float
|
Z coordinate of the start point |
required |
zCoordAtEnd
|
float
|
Z coordinate of the end point |
required |
SetStartPoint(x, y, z)
Set the start point of the element in world coordinate system
Parameters:
Name | Type | Description | Default |
---|---|---|---|
x
|
float
|
y start point coordinate |
required |
y
|
float
|
y start point coordinate |
required |
z
|
float
|
z start point coordinate |
required |
__init__
overload
__init__()
initialize
__init__(structuralBraceProps)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
structuralBraceProps
|
StructuralBraceProperties
|
Structural Brace properties |
required |