Vertical Element Properties
Class full path: NemAll_Python_ArchElements.VerticalElementProperties
Bases: ArchBaseProperties
Implementation of the vertical element properties
Attributes
Angle: Angle
property
writable
Get the angle
Depth: float
property
writable
Get the depth
Radius: float
property
writable
Get the radius
ShapePolygon: Polygon2D
property
writable
Get the shape polygon
Width: float
property
writable
Get the width
Functions
GetAngle()
Get the angle
Returns:
Type | Description |
---|---|
Angle
|
Get angle |
GetDepth()
Get the depth
Returns:
Type | Description |
---|---|
float
|
Depth |
GetRadius()
Get the radius
Returns:
Type | Description |
---|---|
float
|
Radius |
GetShapePolygon()
Get the shape polygon
Returns:
Type | Description |
---|---|
Polygon2D
|
Shape polygon |
GetWidth()
Get the width
Returns:
Type | Description |
---|---|
float
|
Width |
LoadFromFavoriteFile(doc)
Load the properties from the favorite file
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
SetAngle(angle)
Set the angle
Parameters:
Name | Type | Description | Default |
---|---|---|---|
angle
|
Angle
|
Angle |
required |
SetAttribute(attrib)
Set the attribute
Parameters:
Name | Type | Description | Default |
---|---|---|---|
attrib
|
Union[AttributeInteger, AttributeDouble, AttributeString, AttributeEnum]
|
Attribute |
required |
SetCornerRadius(radius)
Set the corner radius
Parameters:
Name | Type | Description | Default |
---|---|---|---|
radius
|
float
|
Corner radius |
required |
SetDepth(depth)
Set the depth
Parameters:
Name | Type | Description | Default |
---|---|---|---|
depth
|
float
|
Set the depth |
required |
SetRadius(radius)
Set the radius
Parameters:
Name | Type | Description | Default |
---|---|---|---|
radius
|
float
|
Radius |
required |
SetShapePolygon(shapePol)
Set the shape polygon
Parameters:
Name | Type | Description | Default |
---|---|---|---|
shapePol
|
Polygon2D
|
Shape polygon |
required |
SetSize(width, depth)
Set the size of the columns
Parameters:
Name | Type | Description | Default |
---|---|---|---|
width
|
float
|
Width |
required |
depth
|
float
|
Depth |
required |
SetWidth(width)
Set the width
Parameters:
Name | Type | Description | Default |
---|---|---|---|
width
|
float
|
Width |
required |
__init__
overload
__init__()
initialize
__init__(elementProp)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
elementProp
|
VerticalElementProperties
|
Column properties |
required |