Allplan Element
Class full path: NemAll_Python_BaseElements.AllplanElement
Functions
GetAttributes()
Get the attributes object
Returns:
Type | Description |
---|---|
Attributes
|
Attributes object |
GetBaseElementAdapter()
Get the model element
Returns:
Type | Description |
---|---|
BaseElementAdapter
|
Model element |
GetCommonProperties()
Get the common properties
Returns:
Type | Description |
---|---|
CommonProperties
|
Common properties |
GetGeometryObject()
Get the geometry object
Returns:
Type | Description |
---|---|
object
|
Geometry object |
GetLabelElements()
Get the label elements TODO: Please check the return type
Returns:
Type | Description |
---|---|
List[LabelElement]
|
Label elements |
SetAttributes(attributesObject)
Set the attributes object
Parameters:
Name | Type | Description | Default |
---|---|---|---|
attributesObject
|
object
|
Attributes object |
required |
SetBaseElementAdapter(ele)
Sel the model element
Parameters:
Name | Type | Description | Default |
---|---|---|---|
ele
|
BaseElementAdapter
|
Model element |
required |
SetCommonProperties(commonProp)
Set the common properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
SetDockingPointsKey(dockingPointKey)
Set the docking points key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
dockingPointKey
|
str
|
Docking points key |
required |
SetGeometryObject(geometryObject)
Set the geometry object
Parameters:
Name | Type | Description | Default |
---|---|---|---|
geometryObject
|
object
|
Geometry object |
required |
SetLabelElements(labelElements)
Set the label elements
Parameters:
Name | Type | Description | Default |
---|---|---|---|
labelElements
|
List[LabelElement]
|
Label elements TODO: Please check the argument type |
required |