Attribute Byte Vec
Class full path: NemAll_Python_BaseElements.AttributeByteVec
Bases: Attribute
Attributes
Id: int
property
Property for id
Value: VecByteList
property
Property for value
Functions
__eq__(props)
Compare operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
props
|
AttributeByteVec
|
Properties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
Properties a equal: true/false |
__init__
overload
__init__()
initialize
__init__(id, value)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
id
|
int
|
Attribute id |
required |
value
|
VecByteList
|
Attribute value |
required |
__repr__()
convert the list to a string