Attributes
Class full path: NemAll_Python_BaseElements.Attributes
Attributes class
Attributes
AttributeSets: typing.List[AttributeSet]
property
Property for attribute set vector
Functions
GetAttributeSets()
Get the AttributeSet vector
Returns:
Type | Description |
---|---|
List[AttributeSet]
|
Attribute value |
SetAttributeSets(sets)
Set the AttributeSet vector
Parameters:
Name | Type | Description | Default |
---|---|---|---|
sets
|
List[AttributeSet]
|
AttributeSet vector |
required |
__eq__(props)
Compare operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
props
|
Attributes
|
Properties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
Properties a equal: true/false |
__init__
overload
__init__()
initialize
__init__(elements)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
elements
|
List[AttributeSet]
|
Attribute set element list |
required |
__repr__()
convert the list to a string