Elements Attribute Service
Class full path: NemAll_Python_BaseElements.ElementsAttributeService
Functions
ChangeAttribute(attributeNumber, newValue, elements)
staticmethod
Change an attribute
Parameters:
Name | Type | Description | Default |
---|---|---|---|
attributeNumber
|
int
|
Attribute number |
required |
newValue
|
object
|
New value |
required |
elements
|
BaseElementAdapterList
|
Elements to change attribute in |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Adapted elements |
ChangeAttributes(attributeDataList, elements)
staticmethod
Change an attribute
Parameters:
Name | Type | Description | Default |
---|---|---|---|
attributeDataList
|
List[Tuple]
|
List with the attribute data as tuple(number, value) |
required |
elements
|
BaseElementAdapterList
|
Elements to change attributes in |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Modified elements |
GetAttributes(ele, readState=ReadAll)
staticmethod
Get the attributes from an element
Parameters:
Name | Type | Description | Default |
---|---|---|---|
ele
|
BaseElementAdapter
|
Element |
required |
readState
|
eAttibuteReadState
|
read state |
ReadAll
|
Returns:
Type | Description |
---|---|
List[Tuple]
|
List attributes represented as tuples (attributeNumber, attributeValue) |