Elements Select Service
Class full path: NemAll_Python_BaseElements.ElementsSelectService
Functions
SelectAllElements(doc)
staticmethod
Select all elements from the document
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
All elements from the document |
SelectElementsByIfcGuid(doc, ifcGuids)
staticmethod
Select elements by IFC guids
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
ifcGuids
|
List[GUID]
|
List with the IFC GUIDs TODO: check the correctness of this arguments type (GUID) |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Elements |