Export Import Service
Class full path: NemAll_Python_BaseElements.ExportImportService
Implementation of the export/import service
Functions
ExportIFC(doc, fileNumbers, ifcVersion, fileName, ifcThemeFileName='')
Export the data to an IFC file
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
fileNumbers
|
Union[List[int], VecIntList]
|
Numbers of the drawing files to export |
required |
ifcVersion
|
IFC_Version
|
IFC version |
required |
fileName
|
str
|
Name of the IFC file |
required |
ifcThemeFileName
|
str
|
Name of the theme file |
''
|
ExportXPlan(doc, fileNumbers, xplanFilePath)
Export the data to an XPlan file
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
fileNumbers
|
Union[List[int], VecIntList]
|
Numbers of the drawing files to export |
required |
xplanFilePath
|
str
|
Path and name of the XPlan file |
required |
ImportIFC(doc, fileNumber, fileName)
Import the data from an IFC file
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
fileNumber
|
int
|
Number of the drawing file for the data import |
required |
fileName
|
str
|
Name of the IFC file |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
List with the imported elements |
__init__
overload
__init__()
initialize
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
ExportImportService
|
Element to copy |
required |