Layout Master Data
Class full path: NemAll_Python_BaseElements.LayoutMasterData
Layout master data
Attributes
BackgroundType: int
property
Set/get the background type (0-none, 1- color, 2-filling/gradient filling, 3 texture)
Border: LayoutBorderDefinition
property
Set/get the border
Filling: LayoutMasterFillingData
property
Set/get the filling
LayoutHeaderOffsetX: float
property
Set/get the horizontal distance between legend frame and inner line of border
LayoutHeaderOffsetY: float
property
Set/get the vertical distance between legend frame and inner line of border
LayoutHeaderType: int
property
Set/get the header type (0-none, 1-stamp, 2-legend)
Legend: LayoutMasterLegendData
property
Set/get the legend
Margin: LayoutMargin
property
Set/get the margin
SheetSize: LayoutSize
property
Set/get the size of the sheet
Stamp: LayoutMasterStampData
property
Set/get the stamp
Texture: LayoutMasterTextureData
property
Set/get the texture
UseBorder: bool
property
Set/get the use border state
UseMargins: bool
property
Set/get the use margins state
UseProperties: bool
property
Set/get the use properties state
Functions
__init__()
initialize