View Section Preview
Class full path: NemAll_Python_BaseElements.ViewSectionPreview
Functions
CollectPreviewElements(doc, generalsectionProperties)
Collect elements for view or section preview
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
generalsectionProperties
|
SectionGeneralProperties
|
General section properties |
required |
DrawPreview(placementPoint, doc, generalsectionProperties, arg)
Draw the view or section preview
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placementPoint
|
Point2D
|
Placement point |
required |
doc
|
DocumentAdapter
|
Document |
required |
generalsectionProperties
|
SectionGeneralProperties
|
General section properties |
required |
arg
|
bool
|
TODO: please rename this argument and provide its explanation |
required |
Returns:
Type | Description |
---|---|
Point3D
|
offset point TODO: please provide more explenation of the returned Point3D |
__init__()
initialize