ARGB
Class full path: NemAll_Python_BasisElements.ARGB
Representation of an ARGB color
Attributes
Alpha: int
property
Property for alpha channel
Blue: int
property
Property for blue channel
Green: int
property
Property for green channel
Red: int
property
Property for red channel
Functions
GetARGB()
returns ARGB color as unsigned long
Returns:
Type | Description |
---|---|
int
|
color as long |
__eq__(argb)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
argb
|
ARGB
|
color to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal |
__init__
overload
__init__()
initialize
__init__(red, green, blue, alpha)
constructor with RGBA components
Parameters:
Name | Type | Description | Default |
---|---|---|---|
red
|
int
|
red component |
required |
green
|
int
|
green component |
required |
blue
|
int
|
blue component |
required |
alpha
|
int
|
alpha component |
required |
__init__(argb)
constructor with ARGB color
Parameters:
Name | Type | Description | Default |
---|---|---|---|
argb
|
int
|
ARGB color |
required |
__init__(argb)
copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
argb
|
ARGB
|
copy from |
required |
__repr__()
convert the list to a string