Associative View Element
Class full path: NemAll_Python_BasisElements.AssociativeViewElement
Bases: AllplanElement
Implementation of the Associative View aka Reinforcement View. Please note, that this views are deprecated since V2023. Use ViewSectionElement instead.
Attributes
ClippingPathProperties: ClippingPathProperties
property
Property for the clipping path properties
DimensionElements: typing.List
property
Property for the dimension elements
PlacementAngle: Angle
property
Property for the placement angle
PlacementPoint: Point3D
property
Property for the placement point
ReinforcementLabels: ReinforcementLabelList
property
Property for the reinforcement labels
SectionAngle: Angle
property
Property for the section angle
SectionPolyhedron: Polyhedron3D
property
Property for the section polyhedron
TextElements: typing.List[TextElement]
property
Property for the text elements
ViewMatrix: Matrix3D
property
Property for the view matrix
ViewProperties: AssociativeViewProperties
property
Property for the view properties
Functions
__init__()
initialize
__repr__()
convert the list to a string