Bitmap Definition
Class full path: NemAll_Python_BasisElements.BitmapDefinition
Attributes
AbsolutePath: str
property
writable
Property for the absolute path
RelativeName: str
property
writable
Property for the bitmap relative name
Functions
Create(bitmapName)
staticmethod
Create a bitmap definition
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bitmapName
|
str
|
Path and name of the bitmap |
required |
Returns:
Type | Description |
---|---|
BitmapDefinition
|
Bitmap definition |
Dump(deep)
Dump bitmap
Parameters:
Name | Type | Description | Default |
---|---|---|---|
deep
|
bool
|
deep dump |
required |
GetBitmapName()
Get the name
Returns:
Type | Description |
---|---|
str
|
Name |
GetHeight()
Get bitmap height
Returns:
Type | Description |
---|---|
int
|
height in pixels |
GetPixel(x, y)
Parameters:
Name | Type | Description | Default |
---|---|---|---|
x
|
int
|
horizontal position |
required |
y
|
int
|
vertical position |
required |
Returns:
Type | Description |
---|---|
int
|
Color as ARGB |
GetWidth()
Get bitmap width
Returns:
Type | Description |
---|---|
int
|
Width in pixels |
IsHDRI()
Is High Dynamic Range Image
Returns:
Type | Description |
---|---|
bool
|
Bitmap is a HDR image |
LoadBitmap()
Load bitmap
Returns:
Type | Description |
---|---|
bool
|
Loading successful |
setName(resourceName)
Set a name
Parameters:
Name | Type | Description | Default |
---|---|---|---|
resourceName
|
str
|
name to assign |
required |