End Symbols Properties
Class full path: NemAll_Python_BasisElements.EndSymbolsProperties
Properties of Start an End Symbols of a ModelElement2D
Attributes
EndID: int
property
Property for end symbol ID
EndSize: float
property
Property for end symbol size
StartID: int
property
Property for start symbol ID
StartSize: float
property
Property for start symbol size
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
EndSymbolsProperties
|
EndSymbolsProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__
overload
__init__()
initialize
__init__(startID, startSize, endID, endSize)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
startID
|
int
|
ID of the start symbol |
required |
startSize
|
float
|
Size of the start symbol |
required |
endID
|
int
|
ID of the end symbol |
required |
endSize
|
float
|
Size of the end symbol |
required |
__repr__()
convert the list to a string