Face Style Properties
Class full path: NemAll_Python_BasisElements.FaceStyleProperties
Properties of Style Area
Attributes
DirectionToReferenceLine: int
property
Property for the edge index of the outline to align the filling to, when the property UseDirectionToReferenceLine is set to true.
FaceStyleID: int
property
Property for the ID of style area
ReferencePoint: Point2D
property
Property for the point of origin, when property UseReferencePoint is set to true
RotationAngle: Angle
property
Property for rotation angle
UseDirectionToReferenceLine: bool
property
Whether to align the direction of the style area to a certain edge. When set to true, the index of the edge is to be specified in the property DirectionToReferenceLine.
UseReferencePoint: bool
property
Whether to use a specific point as the origin of the style area. When set to false, the origin is (0,0). When set to true, the point is to be specified in the property ReferencePoint.
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
FaceStyleProperties
|
FaceStyleProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
initialize
__repr__()
convert the list to a string