Filling Properties
Class full path: NemAll_Python_BasisElements.FillingProperties
Properties of Filling
Attributes
DirectionToReferenceLine: bool
property
Property for the edge index of the outline to align the filling to. Relevant only, when the property UseDirectionToReferenceLine is set to true.
FirstColor: ARGB
property
Property for first color
RotationAngle: Angle
property
Property for rotation angle Relevant only, when the property UseGradientFilling is set to true.
SecondColor: ARGB
property
Property for second color Relevant only, when the property UseGradientFilling is set to true.
ShadingType: ShadingType
property
Property for shading style Relevant only, when the property UseGradientFilling is set to true.
TranslationType: TransitionType
property
Property for color gradients type Relevant only, when the property UseGradientFilling is set to true.
UseDirectionToReferenceLine: bool
property
Whether to align the direction of the filling to a certain edge. When set to true, the index of the edge is to be specified in the property DirectionToReferenceLine.
UseGradientFilling: bool
property
Whether to use gradient filling
VariantType: VariantType
property
Property for gradient variant type Relevant only, when the property UseGradientFilling is set to true.
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
FillingProperties
|
GradientFillingProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
initialize
__repr__()
convert the list to a string