Hatching Element
Class full path: NemAll_Python_BasisElements.HatchingElement
Bases: BasisElement
, AllplanElement
HatchingElement class
Functions
GetHatchingProperties()
Get the hatching properties
Returns:
Type | Description |
---|---|
HatchingProperties
|
Hatching properties |
SetHatchingProperties(hatchingProp)
Set the hatching properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
hatchingProp
|
HatchingProperties
|
Hatching properties |
required |
__init__
overload
__init__()
initialize
__init__(commonProp, hatchingProp, geometryObject)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
hatchingProp
|
HatchingProperties
|
Hatching properties |
required |
geometryObject
|
Polygon2D
|
Polygon representing the hatching outline |
required |
__init__(hatchingElement)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
hatchingElement
|
HatchingElement
|
Hatching element to copy |
required |
__repr__()
convert the list to a string