Hatching Properties
Class full path: NemAll_Python_BasisElements.HatchingProperties
HatchingProperties class
Attributes
BackgroundColor: ARGB
property
Property for background color Relevant only, when the property UseBackgroundColor is set to true.
DirectionToReferenceLine: int
property
Property for the edge index of the outline to align the hatching to. Relevant only, when the property UseDirectionToReferenceLine is set to true.
HatchID: int
property
Property for hatch ID
IsScaleDependent: bool
property
Whether the hatch is to be adjusted to drawing file scale
ReferencePoint: Point2D
property
Property for the point of origin, when property UseReferencePoint is set to true
RotationAngle: Angle
property
Property for rotation angle
UseBackgroundColor: bool
property
Whether to use background color
UseReferencePoint: bool
property
Whether to use a specific point as the origin of the hatching. When set to false, the origin is (0,0). When set to true, the point is to be specified in the property ReferencePoint.
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
HatchingProperties
|
HatchingProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
initialize
__repr__()
convert the list to a string