Library Element Properties
Class full path: NemAll_Python_BasisElements.LibraryElementProperties
Properties of Library Element
Functions
GetElement()
Get the element
Returns:
Type | Description |
---|---|
str
|
Element |
GetElementType()
Get the element type
GetGroup()
Get the group
Returns:
Type | Description |
---|---|
str
|
Group |
GetPath()
Get the path
Returns:
Type | Description |
---|---|
str
|
Path |
GetPlacementMatrices()
Get the placement matrices
Returns:
Type | Description |
---|---|
Matrix3DList
|
Placement matrices |
GetPlacementMatrix()
Get the placement matrix
Returns:
Type | Description |
---|---|
Matrix3D
|
Placement matrix |
GetPolyline()
Get the polygon points in case of a line fixture
Returns:
Type | Description |
---|---|
Polyline3D
|
Polyline points of the line fixture |
GetProducer()
Get the producer
Returns:
Type | Description |
---|---|
str
|
Producer |
SetPolyline(polyline)
Set the polygon points in case of a line fixture
Parameters:
Name | Type | Description | Default |
---|---|---|---|
polyline
|
Polyline3D
|
Polyline of a line fixture |
required |
SetProducer(producer)
Set the producer
Parameters:
Name | Type | Description | Default |
---|---|---|---|
producer
|
str
|
Producer |
required |
__init__
overload
__init__()
initialize
__init__(path, group, element, elementType, placementMatrix)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
path
|
str
|
Path name |
required |
group
|
str
|
Group name |
required |
element
|
str
|
Element name |
required |
elementType
|
LibraryElementType
|
Element type |
required |
placementMatrix
|
Matrix3D
|
Placement point |
required |
__init__(path, group, element, elementType, placementMatrices)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
path
|
str
|
Path name |
required |
group
|
str
|
Group name |
required |
element
|
str
|
Element name |
required |
elementType
|
LibraryElementType
|
Element type |
required |
placementMatrices
|
Matrix3DList
|
Placement matrices |
required |