Macro Element
Class full path: NemAll_Python_BasisElements.MacroElement
Bases: BasisElement
, AllplanElement
Representation of Smart Symbol Definition
Functions
GetHash()
Get the hash value
Returns:
Type | Description |
---|---|
str
|
Hash value |
GetMacroProperties()
Get the Macro properties
Returns:
Type | Description |
---|---|
MacroProperties
|
Macro properties |
GetSlideList()
Get the slide object list
Returns:
Type | Description |
---|---|
List
|
Slide object list |
SetHash(hash)
Set the hash value
Parameters:
Name | Type | Description | Default |
---|---|---|---|
hash
|
str
|
Hash value |
required |
SetMacroProperties(MacroProp)
Set the Macro properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
MacroProp
|
MacroProperties
|
Macro properties |
required |
__init__
overload
__init__()
initialize
__init__(macroProp, slideList)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
macroProp
|
MacroProperties
|
Macro properties |
required |
slideList
|
List[MacroSlideElement]
|
List of macro slides |
required |
__repr__()
convert the list to a string