Macro Placement Element
Class full path: NemAll_Python_BasisElements.MacroPlacementElement
Bases: BasisElement
, AllplanElement
Representation of the Smart Symbol's Instance
Attributes
MacroPlacementProperties: MacroPlacementProperties
property
writable
Property for the smart symbol's properties
Functions
GetArchitectureElementsList()
Get the architecture elements
Returns:
Type | Description |
---|---|
List
|
Architecture elements |
GetAttributesList()
Get the attributes list
Returns:
Type | Description |
---|---|
List[AttributeSet]
|
Attributes list |
GetFixtureElementsList()
Get the fixture elements
Returns:
Type | Description |
---|---|
List
|
Fixture elements |
GetLibraryElementsList()
Get the library elements
Returns:
Type | Description |
---|---|
List[LibraryElement]
|
Library elements |
GetMacro()
Get the corresponding macro definition
Returns:
Type | Description |
---|---|
MacroElement
|
Macro definition element |
GetMacroPlacementProperties()
Get the macro placement properties
Returns:
Type | Description |
---|---|
MacroPlacementProperties
|
MacroPlacement properties |
GetReinforcementList()
Get the reinforcement elements
Returns:
Type | Description |
---|---|
List
|
Reinforcement elements |
SetMacroPlacementProperties(macroPlacementProp)
Set the macro placement properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
macroPlacementProp
|
MacroPlacementProperties
|
MacroPlacement properties |
required |
__init__
overload
__init__()
initialize
__init__(commonProp, macroPlacementProp, macro, reinforcementList, libraryElementList=[], architectureElementsList=[], fixtureElementsList=[])
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
macroPlacementProp
|
MacroPlacementProperties
|
MacroPlacement properties |
required |
macro
|
MacroElement
|
Macro definition element |
required |
reinforcementList
|
List
|
Reinforcement elements |
required |
libraryElementList
|
List
|
Library elements list |
[]
|
architectureElementsList
|
List
|
Architecture elements list |
[]
|
fixtureElementsList
|
List
|
Fixture elements list |
[]
|
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
MacroPlacementElement
|
Element to copy |
required |
__repr__()
Convert to string