Macro Properties
Class full path: NemAll_Python_BasisElements.MacroProperties
Properties of Smart Symbol's Definition
Attributes
CatalogName: str
property
writable
Get the Catalog name
DomainType: int
property
writable
Get the Domain type
InsertionPoint: Point3D
property
writable
Property for the reference point
IsScaleDependent: bool
property
writable
Whether the macro should be scale dependent
Name: str
property
writable
Get the Name
PositionNr: int
property
writable
Property for the mark number
SubType: int
property
writable
Get the Sub type
UnitFactor: float
property
writable
Get the Unit factor
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
MacroProperties
|
MacroProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__
overload
__init__()
initialize
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
MacroProperties
|
Element to copy |
required |
__repr__()
Convert to string