Macro Slide Properties
Class full path: NemAll_Python_BasisElements.MacroSlideProperties
Implementation of the macro slide element properties
Attributes
EndScaleRange: float
property
writable
Property for the reference scale, up to which the slide is drawn
OffsetOfReferencePoint1: Vector3D
property
writable
Get the First offset value to reference point
OffsetOfReferencePoint2: Vector3D
property
writable
Get the Second offset value to reference point
ReferencePoint: Point3D
property
writable
Get the Reference point of this slide
ResizeSettingVx: CombinationType
property
writable
Property for the resizing combination setting for x direction
ResizeSettingVy: CombinationType
property
writable
Property for the resizing combination setting for y direction
ResizeSettingVz: CombinationType
property
writable
Property for the resizing combination setting for z direction
StartScaleRange: float
property
writable
Property for the reference scale, beginning from which the slide is drawn
Type: MacroSlideType
property
writable
Get the Type of macro slide
VisibilityGeo2D: bool
property
writable
Whether the slide should be considered as 2D element (ex. to be visible in ground view)
VisibilityGeo3D: bool
property
writable
Whether the slide should be considered as 3D element (ex. to be visible in isometric view)
VisibilityLayerA: bool
property
writable
Whether the slide should be visible on the smart symbol foil A
VisibilityLayerB: bool
property
writable
Whether the slide should be visible on the smart symbol foil B
VisibilityLayerC: bool
property
writable
Whether the slide should be visible on the smart symbol foil C
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
MacroSlideProperties
|
MacroSlideProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__
overload
__init__()
initialize
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
MacroSlideProperties
|
Element to copy |
required |
__repr__()
Convert to string