Pattern Curve Properties
Class full path: NemAll_Python_BasisElements.PatternCurveProperties
Properties of pattern curve
Attributes
AlignmentType: PatternCurveAlignment
property
Property for the position of the pattern relative to the reference curve
Height: float
property
Property for height of pattern
IntersectionType: PatternCurveIntersectionType
property
Property for intersection type
IsDrawReferenceCurve: bool
property
Whether to draw the reference curve
IsLockedToCorner: bool
property
Whether to lock the corner
IsMirrorPattern: bool
property
Whether to mirror the pattern
IsScaleDependent: bool
property
Whether the pattern is to be scale dependent
PatternID: int
property
Property for pattern ID
Width: float
property
Property for width of pattern
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
PatternCurveProperties
|
PatternCurveProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
initialize
__repr__()
convert the list to a string