Pattern Properties
Class full path: NemAll_Python_BasisElements.PatternProperties
PatternProperties class
Attributes
BackgroundColor: ARGB
property
Property for background color. Relevant only if UseBackgroundColor property is set to true
IsScaleDependent: bool
property
Whether the pattern is to be scale dependent
PatternID: int
property
Property for pattern ID
PlacementType: PlacementType
property
Property for placing mode
ReferencePoint: Point2D
property
Property for reference point. Only relevant if UseReferencePoint is set to true.
RotationAngle: Angle
property
Property for rotation angle
UseBackgroundColor: bool
property
Whether to use a background color in the pattern
UseReferencePoint: bool
property
Whether to use the reference point in ReferencePoint property for the pattern origin
XScalingFactor: float
property
Property for X scaling factor
YScalingFactor: float
property
Property for Y scaling factor
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
PatternProperties
|
PatternProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
initialize
__repr__()
convert the list to a string