Section Along Path Clipping Path View Properties
Class full path: NemAll_Python_BasisElements.SectionAlongPathClippingPathViewProperties
Clipping path view properties
Attributes
DirectionSymbolHeight: float
property
writable
Get the DirectionSymbolHeight
DirectionSymbolNr: int
property
writable
Get the DirectionSymbolNr
IsDirectionSymbolOn: bool
property
writable
Get the IsDirectionSymbolOn
TextParameterProperties: SectionAlongPathTextParameterProperties
property
writable
Access text params
Get the SectionAlongPathTextParameterProperties
Functions
ConvertDirectionSymbolNumberFromViewModel(iPaletteIconNum)
Convert icon number used in WPF palette to symbol number used in Allplan for the same graphical representation
Parameters:
Name | Type | Description | Default |
---|---|---|---|
iPaletteIconNum
|
int
|
number of icon from palette (view model) |
required |
ConvertDirectionSymbolNumberToViewModel()
Convert symbol number used in Allplan to icon number used in WPF palette for the same graphical representation
Returns:
Type | Description |
---|---|
int
|
icon number used in WPF |
GetDirectionSymbolHeightTolerance()
staticmethod
Access tolerances
Returns:
Type | Description |
---|---|
float
|
symbol height tolerance |
__init__
overload
__init__(bInitFromSTW=False)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bInitFromSTW
|
bool
|
|
False
|
__init__(B)
copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
B
|
SectionAlongPathClippingPathViewProperties
|
|
required |
__init__()
dummy, is only needed for the creation of the documentation by MkDocs