Section General Properties
Class full path: NemAll_Python_BasisElements.SectionGeneralProperties
General section properties
Attributes
FilterProperties: SectionFilterProperties
property
Property for the filter properties
FormatProperties: SectionFormatProperties
property
Property for the format properties
HiddenSectionLinesProperties: HiddenSectionLinesProperties
property
Property for the hidden section line properties
LabelingProperties: LabelingProperties
property
Property for the labeling properties
PlacementAngle: float
property
Property for the placement angle
PlacementPoint: Point2D
property
Property for the placement point
PlacementPointType: PlacementPointPosition
property
Property for the placement point position
ShowSectionBody: bool
property
Property for the showing of the section body
Status: State
property
Property for the drawing state
VisibleHiddenEdgesProperties: VisibleHiddenEdgesProperties
property
Property for the visible and hidden edge properties
Classes
PlacementPointPosition
Bases: IntEnum
Placement point position
State
Bases: IntEnum
Drawing state of the section
Attributes
AcceleratedHidden = 2
class-attribute
instance-attribute
Draws section using hidden calculation with higher performance and lower quality
Hidden = 0
class-attribute
instance-attribute
Draws section using hidden calculation
Wire = 1
class-attribute
instance-attribute
Draws a wireframe model
Functions
__init__
overload
__init__()
initialize
__init__(bInitFromSTW)
constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bInitFromSTW
|
bool
|
|
required |