Section Layer Properties
Class full path: NemAll_Python_BasisElements.SectionLayerProperties
Section layer properties
Classes
eVisibilityFilterMode
Bases: IntEnum
Visible filter mode
Attributes
eVisibilityFilterMode_ACTUAL = 2
class-attribute
instance-attribute
Include layer currently set as visible
eVisibilityFilterMode_ALL_LAYERS = 3
class-attribute
instance-attribute
Include all layers
eVisibilityFilterMode_CUSTOM = 0
class-attribute
instance-attribute
Include user-defined layers
eVisibilityFilterMode_Undefined = -1
class-attribute
instance-attribute
Undefined
eVisibilityFilter_Modus_LAYERSET = 1
class-attribute
instance-attribute
Includ layers from print set
Functions
SetLayerProperties(iVisibilityFilterMode, bAreInvisibleLyersStored, layerIdVector)
Set the layer properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
iVisibilityFilterMode
|
int
|
Type of selected filter mode |
required |
bAreInvisibleLyersStored
|
bool
|
true -> Elements in excludedLayerList are filtered out false -> Elements in excludedLayerList are taken into consideration |
required |
layerIdVector
|
VecUShortList
|
Elements belonging to these Layers should be filtered (excluded) from source up to flag bAreInvisibleLyersStored |
required |
__init__()
initialize