Symbol2D Element
Class full path: NemAll_Python_BasisElements.Symbol2DElement
Bases: BasisElement
, AllplanElement
Representation of Point Symbol
Functions
GetSymbol2DProperties()
Get the Symbol2D properties
Returns:
Type | Description |
---|---|
Symbol2DProperties
|
Symbol2D properties |
SetSymbol2DProperties(symbol2DProp)
Set the Symbol2D properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
symbol2DProp
|
Symbol2DProperties
|
Symbol2D properties |
required |
__init__
overload
__init__()
initialize
__init__(commonProp, Symbol2DProp, geometryObject)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
Symbol2DProp
|
Symbol2DProperties
|
Symbol2D properties |
required |
geometryObject
|
object
|
Geometry element, ex. Point2D |
required |
__repr__()
convert the list to a string