Symbol2D Properties
Class full path: NemAll_Python_BasisElements.Symbol2DProperties
Properties of the point symbol
Attributes
Height: float
property
Property for height
IsScaleDependent: bool
property
Property for scale dependency
PrimaryPointNumber: int
property
Property for primary point number
RotationAngle: Angle
property
Property for rotation angle
SecondaryPointNumber: int
property
Property for secondary point number
SymbolID: int
property
Property for symbol ID
Width: float
property
Property for width
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
Symbol2DProperties
|
Symbol2DProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
initialize
__repr__()
convert the list to a string