Symbol3D Properties
Class full path: NemAll_Python_BasisElements.Symbol3DProperties
Properties of Terrain Point
Attributes
ControlPointOffset: float
property
Property for control point offset
DescriptionText: str
property
Property for description text (label)
Height: float
property
Property for height
IsScaleDependent: bool
property
Whether the point is to be scale dependent
IsStation: bool
property
Whether the point is a station
PrimaryPointNumber: int
property
Property for primary point number
RotationAngle: Angle
property
Property for rotation angle
SecondaryPointNumber: int
property
Property for secondary point number
StationCode: float
property
Property for station code
:type: None
SymbolID: int
property
Property for symbol ID
Width: float
property
Property for width
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
Symbol3DProperties
|
Symbol3DProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
initialize
__repr__()
convert the list to a string