Text Element
Class full path: NemAll_Python_BasisElements.TextElement
Bases: BasisElement
, AllplanElement
Implementation of the Text element
Attributes
Text: str
property
writable
Get the text string
TextProperties: TextProperties
property
writable
Get the Text properties
Functions
GetDimensions(doc)
Get the text size
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
Returns:
Type | Description |
---|---|
Vector2D
|
Text size |
GetText()
Get the text string
Returns:
Type | Description |
---|---|
str
|
Text string |
GetTextPoints(doc, refPnt)
Get the text points
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
refPnt
|
Point2D
|
Reference point of the text |
required |
Returns:
Type | Description |
---|---|
Point2DList
|
List with the text points |
Point2DList
|
|
Point2DList
|
|3 6 2| |
Point2DList
|
| | |
Point2DList
|
|7 5| |
Point2DList
|
| | |
Point2DList
|
|0__4____1| |
GetTextProperties()
Get the Text properties
Returns:
Type | Description |
---|---|
TextProperties
|
Text properties |
SetText(text)
Set the text string
Parameters:
Name | Type | Description | Default |
---|---|---|---|
text
|
str
|
Text string |
required |
SetTextProperties(textProp)
Set the Text properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
textProp
|
TextProperties
|
Text properties |
required |
__init__
overload
__init__()
initialize
__init__(commonProp, textProp, text, geometryObject)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
textProp
|
TextProperties
|
Text properties |
required |
text
|
str
|
Text string |
required |
geometryObject
|
object
|
Geometry element |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
TextElement
|
Element to copy |
required |
__repr__()
Convert to string