Text Element List
Class full path: NemAll_Python_BasisElements.TextElementList
List for TextElement objects
Functions
__contains__(value)
Check for a value in the list
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
object
|
Value to check |
required |
Returns:
Type | Description |
---|---|
bool
|
State for value is in the list |
__delitem__(value)
Delete a list item
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
object
|
Value to delete |
required |
__eq__(compare_list)
Compare two lists
Parameters:
Name | Type | Description | Default |
---|---|---|---|
compare_list
|
TextElementList
|
List to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
Lists are equal state |
__getitem__(index)
Get a list item
Parameters:
Name | Type | Description | Default |
---|---|---|---|
index
|
int
|
Index of the item |
required |
Returns:
Type | Description |
---|---|
object
|
Value for the index |
__iadd__(eleList)
Add a list
Parameters:
Name | Type | Description | Default |
---|---|---|---|
eleList
|
List
|
TextElement list |
required |
Returns:
Type | Description |
---|---|
TextElementList
|
Lists with the added elements |
__init__
overload
__init__()
Initialize
__init__(ele)
Constructor with a TextElement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
ele
|
TextElement
|
TextElement |
required |
__init__(eleList)
Constructor with a list of TextElement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
eleList
|
List
|
TextElement list |
required |
__init__()
dummy, is only needed for the creation of the documentation by MkDocs
__iter__()
List iterator
Returns:
Type | Description |
---|---|
Iterator[object]
|
List iterator |
__len__()
Get the list length
Returns:
Type | Description |
---|---|
int
|
Length of the list |
__repr__()
Create a string from the elements of the list
__setitem__(index, value)
Set a list item
Parameters:
Name | Type | Description | Default |
---|---|---|---|
index
|
Union[int, slice]
|
Index of the item |
required |
value
|
object
|
Value to item |
required |
append(value)
Append a list item
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
object
|
Value to append |
required |
extend
overload
extend(iterable)
Add the items from an iterable to the end of the list
Parameters:
Name | Type | Description | Default |
---|---|---|---|
iterable
|
TextElementList
|
Iterable to add |
required |
extend(eleList)
Extend the list
Parameters:
Name | Type | Description | Default |
---|---|---|---|
eleList
|
List
|
TextElement list |
required |
extend()
dummy, is only needed for the creation of the documentation by MkDocs