Text Properties
Class full path: NemAll_Python_BasisElements.TextProperties
Implementation of the text properties
Attributes
Alignment: TextAlignment
property
writable
Alignment of text
BackgroundColor: int
property
writable
Background color of text
ColumnSlopeAngle: Angle
property
writable
Angle of columns
Expansion: NEM_UBYTE_t
property
writable
Get the Background color of text
Font: int
property
writable
Text font ID
FontAngle: Angle
property
writable
Angle of characters (italic)
HasBackgroundColor: bool
property
writable
Whether the text has to hav a background color
HasReferencePoint: bool
property
writable
Whether the text have a reference point
HasTextFrame: bool
property
writable
Whether to draw border around text
HasTransparentBackground: bool
property
writable
Whether the text background is to be transparent
Height: float
property
writable
Height of text in [mm]
IsScaleDependent: bool
property
writable
Whether the text is to be scale dependent
IsUserModifiable: bool
property
writable
Whether the text should be modifiable by the user
LineFeed: float
property
writable
Line feed (spacing) of text in [mm]
TextAngle: Angle
property
writable
The Angle of whole text
TextFrame: TextFrameStruct
property
writable
Get the Text frame pen, stroke color settings
TextFrameColor: int
property
writable
Color ID of the text frame
TextFramePen: int
property
writable
Pen ID of the text frame
TextFrameStroke: int
property
writable
Stroke ID of the text frame
Type: TextType
property
writable
Text type (0 - normal text, >1 variables textbild (itv))
Width: float
property
writable
Get the Width of text in [mm]
WrappedText: bool
property
writable
Whether to enable text wrapping
Functions
GetRatio()
Get ration height/width
Init()
Init section properties with default values
IsDraftText()
check eDraftText property flag
Returns:
Type | Description |
---|---|
bool
|
True if eDraftText is set otherwise false |
SetHasBackgroundColorAndTransparentBackgroundColor(value)
set the flag HasBackgroundColor and HasTransparentBackground
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
bool
|
flag value |
required |
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
TextProperties
|
TextProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__
overload
__init__()
initialize
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
TextProperties
|
Element to copy |
required |
__repr__()
Convert to string