View Section Element
Class full path: NemAll_Python_BasisElements.ViewSectionElement
Bases: AllplanElement
ViewSectionElement class
Attributes
DimensionElements: typing.List[typing.Union[DimensionLineElement, ElevationElement]]
property
Property for the dimension elements
GeneralSectionProperties: SectionGeneralProperties
property
Property for the general section properties
ReinforcementLabels: ReinforcementLabelList
property
Property for the reinforcement labels
SectionDefinitionData: SectionDefinitionData
property
Property for the section definition data
TextElements: typing.List[TextElement]
property
Property for the text elements
ViewMatrix: Matrix3D
property
Property for the view matrix
Functions
CreateSectionBody(doc, insertionMat, object)
Create the section body
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
insertionMat
|
Matrix3D
|
Placement matrix |
required |
DrawElement(modelElements, insertionMat, docID)
Draw element preview in Allplan
Parameters:
Name | Type | Description | Default |
---|---|---|---|
modelElements
|
List[object]
|
list of model elements which should be drawn |
required |
insertionMat
|
Matrix3D
|
insertion matrix |
required |
docID
|
int
|
Document ID |
required |
Returns:
Type | Description |
---|---|
MinMax3D
|
Min/max box of the preview |
__init__()
initialize
__repr__()
convert the list to a string