Conical Surface3D
Class full path: NemAll_Python_Geometry.ConicalSurface3D
3D conical surface
Attributes
Placement: AxisPlacement3D
property
Get and set the placement property
Radius: float
property
Get and set the radius property
SemiAngle: Angle
property
Get and set the semi angle property
Functions
Get()
Get all surface members
Returns:
Type | Description |
---|---|
AxisPlacement3D
|
placement of conical surface, |
float
|
radius of conical surface in placement, |
Angle
|
semi angle of conical surface |
GetPlacement()
returns axis placement of the conical surface
Returns:
Type | Description |
---|---|
AxisPlacement3D
|
placement - point + axis vector + reference direction vector |
GetRadius()
Returns the radius at the placement
Returns:
Type | Description |
---|---|
float
|
radius |
GetSemiAngle()
Returns the value of semi angle of conical surface
Returns:
Type | Description |
---|---|
Angle
|
angle |
IsValid()
Check surface validity
Returns:
Type | Description |
---|---|
bool
|
bool valid = true |
Set(placement, radius, angle)
Set all surface members
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placement
|
AxisPlacement3D
|
placement of conical surface |
required |
radius
|
float
|
radius of conical surface in placement |
required |
angle
|
Angle
|
semi angle of conical surface |
required |
SetPlacement(value)
sets the position of conical surface
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
AxisPlacement3D
|
placement - point + axis vector + reference direction vector |
required |
SetRadius(value)
Sets the radius at the placement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
float
|
radius to be set |
required |
SetSemiAngle(value)
Sets the value of semi angle of conical surface
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
Angle
|
angle to be set |
required |
__eq__(surface)
Comparison of conical surfaces without tolerance.
Be careful, this method work without tolerance!
Parameters:
Name | Type | Description | Default |
---|---|---|---|
surface
|
ConicalSurface3D
|
surface Compared conical surface. |
required |
Returns:
Type | Description |
---|---|
bool
|
True when conical surfaces are equal, otherwise false. |
__init__
overload
__init__()
initialize
__init__(placement, radius, angle)
Constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placement
|
AxisPlacement3D
|
placement of conical surface |
required |
radius
|
float
|
radius at a placement |
required |
angle
|
Angle
|
angle between placement axis and some axis on surface |
required |
__init__(surface)
Copy constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
surface
|
ConicalSurface3D
|
Surface which will be copied. |
required |
__repr__()
convert the list to a string