Hidden Material
Class full path: NemAll_Python_Geometry.HiddenMaterial
Input element settings used by hidden calculation.
Attributes
ExtraSmooth: bool
property
writable
Extra smooth flag for entry.
Flag is usual for elements like round column. Adjacent edges of such element are optimized with constant angle (20 deg) ignoring angle set in hidden options (usual about 1deg).
MaterialNumber: int
property
writable
So called material number of entry.
Elements with same material numbers are threaded specially depending on settings of hidden calculation e.g suspended lines between them etc. Value 0 means no material set.
Functions
__init__
overload
__init__()
initialize
__init__(source)
Copy constructor.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
source
|
HiddenMaterial
|
Source. |
required |