Intersect Ray Polyhedron Flag
Class full path: NemAll_Python_Geometry.IntersectRayPolyhedronFlag
Bases: IntEnum
Attributes
eNegativeIfNoPositive = 1
class-attribute
instance-attribute
allow negative intersections, but only if not positive intersection can be found; prefer intersections with lambda close to 0 (i.e., prefer -1 over -2)
eNegativePreferred = 2
class-attribute
instance-attribute
search for the intersection with the smallest lambda, prefer negative over positive, prefer -2 over -1 (this is a simple linear comparison)
ePositiveOnly = 0
class-attribute
instance-attribute
allow only intersections with lambda >= 0, prefer the smallest one
eSmallestLmabda = 3
class-attribute
instance-attribute
search for the intersection with the smallest lambda
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
Union[str, int, float]
|
value key |
required |
Returns:
Type | Description |
---|---|
IntersectRayPolyhedronFlag
|
value for the key |