Skip to content

Coordinate Input

Class full path: NemAll_Python_IFW_Input.CoordinateInput

Bases: InputViewDocumentData

Functions

AddGeometryFromPreviewElements(arg2)

Add the geometry elements from the preview elements for the point and element search

CancelInput()

Explicit cancel of the input function

GetAssocViewFromPoint(mouseMsg, pnt, pMsgInfo)

Get associative view element adapter from the input point

Parameters:

Name Type Description Default
mouseMsg int

Mouse message WM_xxx

required
pnt Point2D

Cursor point (view coordinate)

required
pMsgInfo AddMsgInfo

Additional message info

required

Returns:

Type Description
AssocViewElementAdapter

Adapter to associative view element

GetCurrentPoint overload

GetCurrentPoint()

Get and mark the current input point

Returns:

Type Description
CoordinateInputResult

Current input point

GetCurrentPoint(startPnt)

Get and mark the current input point

Parameters:

Name Type Description Default
startPnt Point3D

Starting point End point input is possible by a distance input to the start point

required

Returns:

Type Description
CoordinateInputResult

Current input point

GetCurrentPoint(startPnt, bStartPnt)

Get and mark the current input point

Parameters:

Name Type Description Default
startPnt Point3D

Starting point

required
bStartPnt bool

Starting point is active End point input is possible by a distance input to the start point

required

Returns:

Type Description
CoordinateInputResult

Current input point

GetCurrentPoint(bStartPnt)

Get and mark the current input point

End point input is possible by a distance input to the input point

of the last input step

Parameters:

Name Type Description Default
bStartPnt bool

Starting point is active true/false.

End point input is possible by a distance input to the input point

of the last input step

required

Returns:

Type Description
CoordinateInputResult

Current input point

GetInputControlIntValue()

Get the integer value from the value input control

Returns:

Type Description
int

Integer value from the value input control

GetInputControlValue()

Get the double value from the value input control

Returns:

Type Description
float

Double value from the value input control

GetInputPoint overload

GetInputPoint(mouseMsg, pnt, pMsgInfo)

Get the current input point

Parameters:

Name Type Description Default
mouseMsg int

Mouse message WM_xxx

required
pnt Point2D

Cursor point (view coordinate)

required
pMsgInfo AddMsgInfo

Additional message info

required

Returns:

Type Description
CoordinateInputResult

Current input point result

GetInputPoint(mouseMsg, pnt, pMsgInfo, bStartPnt)

Get the current input point

End point input is possible by a distance input to the input point

of the last input step

Parameters:

Name Type Description Default
mouseMsg int

Mouse message WM_xxx

required
pnt Point2D

Cursor point (view coordinate)

required
pMsgInfo AddMsgInfo

Additional message info

required
bStartPnt bool

Starting point is active

End point input is possible by a distance input to the input point of the last input step

required

Returns:

Type Description
CoordinateInputResult

Current input point result

GetInputPoint(mouseMsg, pnt, pMsgInfo, startPnt, bStartPnt)

Get the current input point

End point input is possible by a distance input to the start point

Parameters:

Name Type Description Default
mouseMsg int

Mouse message WM_xxx

required
pnt Point2D

Cursor point (view coordinate)

required
pMsgInfo AddMsgInfo

Additional message info

required
startPnt Point3D

Starting point

required
bStartPnt bool

Starting point is active

End point input is possible by a distance input to the start point

required

Returns:

Type Description
CoordinateInputResult

Current input point result

GetSelectedElement()

Get the selected element

The function can be used in case of eIdentMode = MODE_TEXTPOINT, SelectGeometryElement, SelectElement, ...

Returns:

Type Description
BaseElementAdapter

Selected element

GetSelectedGeometryElement()

InitFirstElementInput(text, identMode=<span data-autorefs-optional-hover="NemAll_Python_IFW_Input.CoordinateInputMode">CoordinateInputMode</span>)

Initialize the coordinate input for an element (point, line, ...) input as free point input. The coordinate input toolbar shows only the request string.

The input is allowed in each document.

Parameters:

Name Type Description Default
text InputStringConvert

Request string

required
identMode CoordinateInputMode

Identification mode

CoordinateInputMode

InitFirstElementValueInput(text, ctrlData, identMode=<span data-autorefs-optional-hover="NemAll_Python_IFW_Input.CoordinateInputMode">CoordinateInputMode</span>)

Initialize the coordinate input for an element (point, line, ...) input as free point input. The coordinate input toolbar shows only the request string and the value input controls.

The input is allowed only in the document from the last input

Parameters:

Name Type Description Default
text InputStringConvert

Request string

required
ctrlData ValueInputControlData

settings for the value input control

required
identMode CoordinateInputMode

Identification mode

CoordinateInputMode

InitFirstPointInput(text, identMode=<span data-autorefs-optional-hover="NemAll_Python_IFW_Input.CoordinateInputMode">CoordinateInputMode</span>)

Initialize the coordinate input for a first point input.

The input is allowed in each document

Parameters:

Name Type Description Default
text InputStringConvert

Request string

required
identMode CoordinateInputMode

Identification mode

CoordinateInputMode

InitFirstPointValueInput(text, ctrlData, identMode=<span data-autorefs-optional-hover="NemAll_Python_IFW_Input.CoordinateInputMode">CoordinateInputMode</span>)

Initialize the coordinate input for a first point and value input.

The input is allowed in each document

Parameters:

Name Type Description Default
text InputStringConvert

Request string

required
ctrlData ValueInputControlData

settings for the value input control

required
identMode CoordinateInputMode

Identification mode

CoordinateInputMode

InitNextElementInput(text, identMode=<span data-autorefs-optional-hover="NemAll_Python_IFW_Input.CoordinateInputMode">CoordinateInputMode</span>)

Initialize the coordinate input for an element (point, line, ...) input as free point input. The coordinate input toolbar shows only the request string.

The input is allowed only in the document from the last input

Parameters:

Name Type Description Default
text InputStringConvert

Request string as resource ID, CAllstring, TCHAR or CString

required
identMode CoordinateInputMode

Identification mode

CoordinateInputMode

InitNextElementValueInput(text, ctrlData, identMode=<span data-autorefs-optional-hover="NemAll_Python_IFW_Input.CoordinateInputMode">CoordinateInputMode</span>)

Initialize the coordinate input for an element (point, line, ...) input as free point input. The coordinate input toolbar shows only the request string and the value input controls.

The input is allowed only in the document from the last input

Parameters:

Name Type Description Default
text InputStringConvert

Request string as resource ID, CAllstring, TCHAR or CString

required
ctrlData ValueInputControlData

settings for the value input control

required
identMode CoordinateInputMode

Identification mode

CoordinateInputMode

InitNextPointInput(text, identMode=<span data-autorefs-optional-hover="NemAll_Python_IFW_Input.CoordinateInputMode">CoordinateInputMode</span>)

Initialize the coordinate input for a next point input.

The input is allowed only in the document from the last input

Parameters:

Name Type Description Default
text InputStringConvert

Request string as resource ID, CAllstring, TCHAR or CString

required
identMode CoordinateInputMode

Identification mode

CoordinateInputMode

InitNextPointValueInput(text, ctrlData, identMode=<span data-autorefs-optional-hover="NemAll_Python_IFW_Input.CoordinateInputMode">CoordinateInputMode</span>)

Initialize the coordinate input for a first point and value input

The input is allowed only in the document from the last input

Parameters:

Name Type Description Default
text InputStringConvert

Request string as resource ID, CAllstring, TCHAR or CString

required
ctrlData ValueInputControlData

settings for the value input control

required
identMode CoordinateInputMode

Identification mode

CoordinateInputMode

InitValueInput(text, ctrlData)

Initialize the value input

Parameters:

Name Type Description Default
text InputStringConvert

Request string as resource ID, CAllstring, TCHAR or CString

required
ctrlData ValueInputControlData

settings for the value input control

required

IsEmptyValueInputControl()

Check, whether there is no input inside the input control

Returns:

Type Description
bool

Input control is empty: true/false

IsMouseMove(mouseMsg)

Check on mouse move

Parameters:

Name Type Description Default
mouseMsg int

Mouse message WM_xxx

required

Returns:

Type Description
bool

Mouse move: true false

IsValueInputControl overload

IsValueInputControl(id)

Check, whether the ID belongs to the value input control (from the coordinate input dialog)

Parameters:

Name Type Description Default
id int

ID to check

required

Returns:

Type Description
bool

ID belongs to the value input control (from the coordinate input dialog): true/false

IsValueInputControl()

Check, whether a value input control exists

Returns:

Type Description
bool

A value input control exists: true/false

IsValueInputControlInput(bIdentPoint)

Check, whether an input inside the value input control is done and the value should be used

Parameters:

Name Type Description Default
bIdentPoint bool

Identification point has higher priority: true/false

required

Returns:

Type Description
bool

Check, whether the input value inside the added control

SelectElement overload

SelectElement(mouseMsg, pnt, pMsgInfo, bHighlight, bSelAlways, bAllowCenter)

Select an element if no identification point exists. Use the filter set by

SetElementFilter

Parameters:

Name Type Description Default
mouseMsg int

Mouse message WM_xxx

required
pnt Point2D

Cursor point (view coordinate)

required
pMsgInfo AddMsgInfo

Additional message info

required
bHighlight bool

Highlight the selected element

required
bSelAlways bool

true: Select always

required
bAllowCenter bool

Allow element identification by center point

required

Returns:

Type Description
bool

Element is selected: true false

SelectElement(mouseMsg, pnt, pMsgInfo, bHighlight, bSelAlways, bAllowCenter, selectSetting)

Select an element if no identification point exists. Use the filter set by

SetElementFilter

Parameters:

Name Type Description Default
mouseMsg int

Mouse message WM_xxx

required
pnt Point2D

Cursor point (view coordinate)

required
pMsgInfo AddMsgInfo

Additional message info

required
bHighlight bool

Highlight the selected element

required
bSelAlways bool

true: Select always

required
bAllowCenter bool

Allow element identification by center point

required
selectSetting ElementSelectFilterSetting

Element selection filter

required

Returns:

Type Description
bool

Element is selected: true false

SelectGeometryElement(mouseMsg, pnt, pMsgInfo, bHighlightCompleteElement)

Select a base geometry element. Use the filter set by SetGeometryElementFilter and SetGeometryFilter

Parameters:

Name Type Description Default
mouseMsg int

Mouse message WM_xxx

required
pnt Point2D

Cursor point (view coordinate)

required
pMsgInfo AddMsgInfo

Additional message info

required
bHighlightCompleteElement bool

true = highlight the complete element, false = highlight only the selected geometry part

required

Returns:

Type Description
bool

Element was found: true false

SelectPolyhedronFace(arg2, arg3, arg4)

.. deprecated:: since Allplan 2023-1-0 use FaceSelectService::SelectPolyhedronFace

SelectWallFace(arg2, arg3, arg4)

.. deprecated:: since Allplan 2023-1-0 use FaceSelectService::SelectWallFace

SelectWallFaceInUVS(arg2, arg3, arg4)

.. deprecated:: since Allplan 2023-1-0 use FaceSelectService::SelectWallFaceInUVS

SetAbscissaLine(arg2, arg3)

SetGeometryFilter(geoFilter)

Set the geometry element selection filter

Parameters:

Name Type Description Default
geoFilter SnoopElementGeometryFilter

Geometry element filter

required

SetInputPlane(plane)

Set the input plane

The input point will be transformed to the input plane: true/false

Parameters:

Name Type Description Default
plane Plane3D

Input plane

required

SetInputText(text)

Set the input text

Parameters:

Name Type Description Default
text InputStringConvert

Request string

required

SetProjectionBase0(setProjectionBase0)

Set the projection base of the coordinate selection

Parameters:

Name Type Description Default
setProjectionBase0 bool

when set to True the input plane normal coordinate is set to 0, otherwise the input plane normal coordinate is used from the selected point

required

__init__()

initialize