Input View Document Data
Class full path: NemAll_Python_IFW_Input.InputViewDocumentData
Functions
EnableAssistWndClick(bEnable)
Enable/disable a click inside the assist window
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bEnable
|
bool
|
Enable a click inside the assist window: 1/0 |
required |
GetActiveViewDocument()
Get the active view document
Returns:
Type | Description |
---|---|
DocumentAdapter
|
active view document |
GetInputViewDocument()
Get the input view document
Returns:
Type | Description |
---|---|
DocumentAdapter
|
Input view document |
GetInputViewDocumentID()
Get the document ID of the current input view.
Returns:
Type | Description |
---|---|
int
|
Document ID of the current input view |
GetViewWorldProjection()
Get the view-world projection object
Returns:
Type | Description |
---|---|
ViewWorldProjection
|
View-world projection object |
__init__()
initialize