Polygon Input
Class full path: NemAll_Python_IFW_Input.PolygonInput
Bases: CoordinateInput
, InputViewDocumentData
Implementation of the polygon input
Functions
ExecuteInput(mouseMsg, pnt, pMsgInfo)
staticmethod
Execute the input
Parameters:
Name | Type | Description | Default |
---|---|---|---|
mouseMsg
|
int
|
Mouse message |
required |
pnt
|
Point2D
|
View input point |
required |
pMsgInfo
|
AddMsgInfo
|
Additional message info |
required |
Returns:
Type | Description |
---|---|
int
|
execution state |
GetPolygon()
staticmethod
get the final polygon
Returns:
Type | Description |
---|---|
Polygon2D
|
final polygon |
GetPreviewPolygon()
staticmethod
get the preview polygon
Returns:
Type | Description |
---|---|
Polygon2D
|
preview polygon |
StartNewInput()
staticmethod
Start new input
__init__(coordInput, bZCoord)
Initialize polygon input
Parameters:
Name | Type | Description | Default |
---|---|---|---|
coordInput
|
CoordinateInput
|
Coordinate input |
required |
bZCoord
|
bool
|
when False, the Z-Coordinate is set to 0 |
required |