Polyline Input
Class full path: NemAll_Python_IFW_Input.PolylineInput
Bases: CoordinateInput
, InputViewDocumentData
Implementation of the polyline input
Functions
ExecuteInput(mouseMsg, pnt, pMsgInfo)
Execute the input
Parameters:
Name | Type | Description | Default |
---|---|---|---|
mouseMsg
|
int
|
Mouse message |
required |
pnt
|
Point2D
|
View input point |
required |
pMsgInfo
|
AddMsgInfo
|
Additional message info |
required |
Returns:
Type | Description |
---|---|
int
|
execution state |
GetPolyline()
get the final polyline
Returns:
Type | Description |
---|---|
Polyline2D
|
final polyline |
GetPreviewPolyline()
get the preview polyline
Returns:
Type | Description |
---|---|
Polyline2D
|
preview polyline |
StartNewInput()
Start new input
__init__(coordInput, bZCoord)
Initialize polyline input
Parameters:
Name | Type | Description | Default |
---|---|---|---|
coordInput
|
CoordinateInput
|
Coordinate input |
required |
bZCoord
|
bool
|
when False, the Z-Coordinate is set to 0 |
required |